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What are Macros?

» A Macro is a ptece of programming code that runs in excel environment, and it helps to automate routine

tasks. In other words, a macro (s a recording of your regular steps in excel, which you can replay using a

single button.

» When you create a macro, you are recording your mouse clicks and keystrokes. After you create a
macro, you can edit it to make minor changes to the way it works. You can use a macro as many times

as you want. It reduces the amount of time you will require to do a task.

> Suppose that every month, you create a report for your accounting manager. You want to format the
names of the customers with overdue accounts in red, and also apply bold formatting. You can create

and then run a macro that quickly applies these formatting changes to the cells you select.



What is VBA?

» Visual Basic for applications (VBA for short) is a programming environment designed
to work with Microsoft's Office applications (Word, Excel, Access, and PowerPoint).

» Components in each application (for example, worksheets or documents) are
exposed as objects to the programmer to use and manipulate to a desired end.
Almost anything you can do through the normal use of the Office application can
also be automated through programming.

» The main difference between VBA and Macro is that VBA is the programming
language to create Macros while Macros are programming codes that run on

Excel environment to perform automatic routine tasks.




Why use VBA & Macros?

>

Automates repetitive and routine tasks: By learning VBA, a process such as receiving emails

in Outlook, generating and sending a responding email, processing data in Excel, and even
copy and paste work becomes easy.

Accessibility to other users: With VBA, other users do not have to install anything provided
you write a script for everyone in the department. VBA can also allow you to add user-friendly

variables that other users can modify to a certain degree. All in all, there is quick access to
information from other users.

Reduces the turnaround time: People working in the finance department are always under

pressure to submit back their reports. It's usually a tedious task for them and which under
stressful conditions may lead to inaccurate reports. VBA removes this burden and makes it
easy to prepare reports and templates within a short time.



Getting Started

Macros and VBA tools can be found on the

Developer tab, which (s hidden by default, so

the first step is to enable it.

To enable developer tab:

1.

Right click on any existing tab on the
ribbon

Select Customize Ribbon.

Under Customize the Ribbon and under
Main Tabs, select the Developer check

box.
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Developer Tab

The Developer tab is the place to go when you want
to do or use the following:

>
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Write macros.

Run macros that you previously recorded.

Use XML commands.

Use ActiveX controls.
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My First Macro

There are two ways to create a macro

1. By recording a macro: Recording a macro (s the simplest way to create
a macro. One doesn’t need any prior knowledge of VBA or programming
to use it. Once you start recording a macro, you only need to carry out
your task, how you would've carried it out in general. Excel will translate
each step that you do (n a language that it understands and create a
macro.

2. By writing your own code: To overcome limitations in recording a
macro, one can create a macro by writing their own code.




Recording a Macro

The steps to record a macro are as follows: dome et Pelyor fomuss Di

1. Click the Developer Tab

2. In the Code group, click on the Macro button. This will Eol= & {1? F,

open the ‘Record Macro’ dialog box.

3. In the Record Macro dialog box, enter a name for your
macro. | am using the name EnterText. Remember that
you cannot use spaces in between.

4.  You can assign a keyboard shortcut if you want. In this
case, we will use the shortcut Control + Shift + N.
Remember that the shortcut you assign here would
override any existing shorcuts (n your workbook.

Basic

Note: For example, if you assign the shortcut Control + S, you will not be able to use
this for saving the workbook (instead, every time you use it, it will execute the macro)
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Recording a Macro

6.

S N

In the ‘Store macro in’ option, make sure ‘This
Workbook’ is selected. This step ensures that
the macro (s a part of the workbook. It will be
there when you save (t and reopen again, or
even If you share it with someone.

You can enter a description if you want.

Click OK. As soon as you click OK, it starts to
record your actions in Excel. You can see the
'Stop recording’ button in the Developer tab,
which indicates that the macro recording is (n
progress.
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Recording a Macro

Once you have started recording a macro you can start carrying out your task and
every single action will be recorded. For example:

» Type your name in the active cell

» Move the cell pointer to the cell below and enter this formula: =NOW()

> Select the formula cell, and press Ctrl+C to copy that cell to the Clipboard.
» Choose Home =Clipboard =Paste =Values (V).

> With the date cell selected, press Shift+up arrow to select that cell and the one
above it (which contains your name).

» Use the controls in the Home =Font group to change the formatting to Bold
and make the font size 16 point.

» Choose Developer =Code =Stop Recording



Running a Macro

There are multiple ways to run a macro:

» To run your macro, move to an empty cell and
press Ctrl+Shift+N (or whatever shortcut you
assigned)

OR

» Choose Developer =Code =>Macros (or press
Alt+F8) to display the Macros dialog box.

» Select the macro from the list (in this case,
NameAndTime), and click Run.

(Ensure that you have cleared what you have typed in
the workbook to determine whether the macro (s
working correctly.)
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Running Macros Through Button

Another method to run a macro is by assigning a

button to [t Data Review View
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Developer

Properties
@view Code
El Run Dialog

Controls

Review View Developer

3. In the options that appear, in the Form
Controls options, click on the Button (Form e
Control) option. -

F Controls

O MEIE @
[ Ae & B EQ ER
ActiveX Controls
OEA M EE E 3
Heo A& 1§

E'—\ Properties
1% AN

gl View Code
de [ElRun Dialog



Running Macros Through Button

4. Click anywhere on the worksheet. This will insert the
button wherever you click and automatically open the

Assign Macro’ dialog box. i i
5. In the Assign Macro dialog box, you will see a list of all the et
macros that you have in the workbook Modro3 I

;‘J Macrod

6. Click the Macro name that you want to assign to this

button. In this example, | will click on the macro named
EnterText’

Macros in: | All Open Workbooks

7. Click on OK Description

Whenever you will press the button it will run that respective
macro.
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Absolute Vs Relative Reference

> Just like absolute & relative reference in excel there (s the same concept in macros
too.

> If you use an absolute reference option to record a macro, the VBA code would
always refer to the same cells that you used.

> For example, if you select cell A2, enter the text Excel and press Enter, every time —
no matter where you are in the worksheet and no matter which cell is selected,
your code would first select cell A2, enter the text Excel, and then move to cell A3.

> If you use a relative reference option to record a macro, VBA wouldn't hardcode
the cell references. Rather, it would focus on the movement when compared with
the active cell

> For example, suppose you already have cell AT selected, and you start recording
the macro (n the relative reference mode. Now you select cell A2, enter the text
Excel, and hit the enter key. Now, when you run this macro, it will not go back to
cell A2, instead, it will move relative to the active cell.

» You can switch on relative reference: Developer =Code =>Use Relative Reference.




What Recording a Macro does in the i : l

Backend?

Now let’s go to the Excel backend — the VB

Editor — and see what recording a macro

really does.

Here are the steps to open the VB Editor (n

Excel:

1. Click the Developer tab.

2. In the Code group, click the Visual Basic
button.
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and press F11)



VBA Sheet Parts
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VBA Sheet Parts

>

Menu Bar: This is where you have all the options of VB Editor. Consider this as the ribbon of VBA.
It contains commands that you can use while working with the VB Editor.

Toolbar — This is like the Quick Access Toolbar of the VB editor. It comes with some useful options,
and you can add more options to (t. Its benefit is that an option in the toolbar (s just a click away.

Project Explorer Window — This is where Excel lists all the workbooks and all the objects in each
workbook. For example, if we have a workbook with 3 worksheets, it would show up in the

Project Explorer. There are some additional objects here such as modules, user forms, and class
modules.

Code Window — This (s where the VBA code is recorded or written. There is a code window for
each object listed in the Project explorer — such as worksheets, workbooks, modules, etc. We will
see later in this tutorial that the recorded macro goes into the code window of a module.

Properties Window — You can see the properties of each object in this window. To show this, click
the view tab and select Properties Window.

Immediate Window —It's useful when you want to test some statements or while debugging. You
can make it appear by clicking the View tab and selecting the Immediate Window option.



A
-

What happened when we recorded a macro?
When we recorded the macro — EnterText, the following things happened in
the VB Editor:

1. A new module was inserted.

2. A macro was recorded with the name that we specified — EnterText

3. The code was written in the code window of the module.

So if you double-click on the module (Module 1 in this case), a code window
as shown below would appear.

» You can edit the code as you want, maybe change the name or font.

» When you rerun the macro, you will see that changes have replicated (n
the excel too.



What happened when we recorded a macro?

=-%% VBAProject (Bookl)
=5 Microsoft Excel Objects
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Saving Workbooks with Macro

> If you store one or more macros in a
workbook, the file must be saved as a
macro-enabled file type. Microsoft Excel X

> ln Other WOde, the ﬁ[e must be Saved The following features cannot be saved in macro-free workbooks:
with an XLSM extension rather than + VB projed
the normal XLSX extension. o

To save a file with these features, click No, and then choose a macro-enabled file type in the File Type list.

> While SaVing your flle a dlalog box will To continue saving as a macro-free workbook, dlick Ves,
appear reminding you to save it as a Yes No Help
macro enabled file.




Limitations of Recording a Macro

Macro recorder is great at following you in Excel and recording your exact steps, but it may
fail you when you need it to do more.

> You can't execute a code without selecting the object.
» You can't create a custom function with a macro recorder.

» You can't run codes based on Events: In VBA you can use many events — such as opening a
workbook, adding a worksheet, double-clicking on a cell, etc, to run a code associated with that
event. You can use a macro recorder to do this.

> You can't create loops with a macro recorder

» You can’t analyze conditions: You can check for conditions within the code using macro recorder.
If you write a VBA code manually, you can use the IF Then Else statements to analyze a condition
and run a code if true (or another code if false).

> You can't pass arguments in a macro procedure: When you record a macro, it will never have any
arguments. A subroutine can take input arguments that can be used within the macro to perform
a task.
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